human-icon-theme-0.36.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit gnome2-utils
  5. DESCRIPTION="A nice and well polished icon theme"
  6. HOMEPAGE="http://packages.ubuntu.com/lucid/human-icon-theme"
  7. SRC_URI="mirror://ubuntu/pool/universe/h/${PN}/${PN}_${PV}.tar.gz
  8. https://www.gentoo.org/images/gentoo-logo.svg"
  9. LICENSE="CC-BY-SA-2.5"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RESTRICT="binchecks strip"
  14. RDEPEND="|| ( x11-themes/tangerine-icon-theme x11-themes/adwaita-icon-theme )"
  15. DEPEND=">=gnome-base/librsvg-2.34
  16. >=x11-misc/icon-naming-utils-0.8.90
  17. dev-util/intltool
  18. sys-devel/gettext"
  19. S=${WORKDIR}/${PN}
  20. DOCS="AUTHORS"
  21. src_prepare() {
  22. sed -i -e 's:lib/icon-naming-utils/icon:libexec/icon:' Makefile || die
  23. sed -i -e '/SVGCONVERT/s:rsvg:&-convert:' svg2png.sh.in || die #414971
  24. cp "${DISTDIR}"/gentoo-logo.svg scalable/places/start-here.svg || die
  25. local res
  26. for res in 22 32 48; do
  27. rsvg-convert -w ${res} -h ${res} scalable/places/start-here.svg \
  28. > ${res}x${res}/places/start-here.png || die
  29. done
  30. }
  31. src_compile() {
  32. emake index.theme
  33. }
  34. pkg_preinst() { gnome2_icon_savelist; }
  35. pkg_postinst() { gnome2_icon_cache_update; }
  36. pkg_postrm() { gnome2_icon_cache_update; }