nimbus-0.1.7-r1.ebuild 1.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTO_DEPEND=no
  5. inherit autotools gnome2-utils
  6. DESCRIPTION="The default OpenSolaris theme (GTK+ 2.x engine, icon- and metacity theme)"
  7. HOMEPAGE="http://dlc.sun.com/osol/jds/downloads/extras/nimbus/"
  8. SRC_URI="http://dlc.sun.com/osol/jds/downloads/extras/${PN}/${P}.tar.bz2"
  9. LICENSE="LGPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  12. IUSE="gtk minimal"
  13. COMMON_DEPEND="gtk? ( x11-libs/gtk+:2 )"
  14. RDEPEND="${COMMON_DEPEND}
  15. !minimal? ( || ( x11-themes/adwaita-icon-theme x11-themes/tango-icon-theme ) )"
  16. DEPEND="${COMMON_DEPEND}
  17. dev-util/intltool
  18. virtual/pkgconfig
  19. >=x11-misc/icon-naming-utils-0.8.90
  20. !gtk? ( ${AUTOTOOLS_DEPEND} )
  21. elibc_Interix? ( ${AUTOTOOLS_DEPEND} )"
  22. src_prepare() {
  23. # Tango is deprecated
  24. sed -i -e '/^Inherits/s:Tango:gnome,&:' icons/index.theme.in || die
  25. # Encoding= key is obsolete
  26. sed -i -e '/^Encoding/d' *.theme.in || die
  27. use gtk || { sed -i \
  28. -e '/^gtk-engine/d' -e '/GTK2/d' -e '/^SUBDIRS/s:gtk-engine ::' \
  29. configure.in Makefile.am || die; }
  30. local f=po/POTFILES.skip
  31. echo light-index.theme.in >> ${f}
  32. echo dark-index.theme.in >> ${f}
  33. if [[ ${CHOST} == *-interix* ]] || ! use gtk; then
  34. eautoreconf
  35. fi
  36. }
  37. src_configure() {
  38. econf $(use gtk && echo --disable-static)
  39. }
  40. src_install() {
  41. emake DESTDIR="${D}" install
  42. dodoc AUTHORS ChangeLog
  43. use gtk && find "${ED}"/usr -name libnimbus.la -exec rm -f {} +
  44. }
  45. pkg_preinst() { gnome2_icon_savelist; }
  46. pkg_postinst() { gnome2_icon_cache_update; }
  47. pkg_postrm() { gnome2_icon_cache_update; }