nuovo-icon-theme-0.5.ebuild 759 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome2-utils
  5. DESCRIPTION="A scalable icon theme called Nuovo"
  6. HOMEPAGE="http://www.silvestre.com.ar/"
  7. SRC_URI="http://www.silvestre.com.ar/icons/dlg-nuovo-${PV}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="minimal"
  12. RDEPEND="!minimal? ( x11-themes/adwaita-icon-theme )"
  13. DEPEND=""
  14. RESTRICT="binchecks strip"
  15. S=${WORKDIR}
  16. src_install() {
  17. dodoc Nuovo/{AUTHORS,Changelog,README}
  18. rm -f Nuovo/{AUTHORS,Changelog,COPYING,DONATE,INSTALL,README}
  19. insinto /usr/share/icons
  20. doins -r Nuovo
  21. }
  22. pkg_preinst() { gnome2_icon_savelist; }
  23. pkg_postinst() { gnome2_icon_cache_update; }
  24. pkg_postrm() { gnome2_icon_cache_update; }