silver-xcursors-0.4.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. MY_P="5533-Silver-XCursors-3D-${PV}"
  4. DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
  5. HOMEPAGE="http://www.kde-look.org/content/show.php?content=5533"
  6. SRC_URI="http://www.kde-look.org/CONTENT/content-files/$MY_P.tar.bz2"
  7. LICENSE="LGPL-2.1"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86 ~x86-fbsd"
  10. IUSE=""
  11. RDEPEND=""
  12. DEPEND="${RDEPEND}"
  13. src_install() {
  14. dodir /usr/share/cursors/xorg-x11/Silver/cursors/
  15. cp -R "${WORKDIR}"/${MY_P:5}/Silver/cursors "${D}"/usr/share/cursors/xorg-x11/Silver/ || die
  16. dodoc "${WORKDIR}"/${MY_P:5}/README
  17. }
  18. pkg_postinst() {
  19. einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
  20. einfo "and add the following line:"
  21. einfo "Xcursor.theme: Silver"
  22. einfo ""
  23. einfo "You can change the size by adding a line like:"
  24. einfo "Xcursor.size: 48"
  25. einfo ""
  26. einfo "Also, to globally use this set of mouse cursors edit the file:"
  27. einfo " /usr/share/cursors/xorg-x11/default/index.theme"
  28. einfo "and change the line:"
  29. einfo " Inherits=[current setting]"
  30. einfo "to"
  31. einfo " Inherits=Silver"
  32. einfo ""
  33. einfo "Note this will be overruled by a user's ~/.Xdefaults file."
  34. einfo ""
  35. ewarn "If you experience flickering, try setting the following line in"
  36. ewarn ""
  37. ewarn "the Device section of your xorg.conf file:"
  38. ewarn " Option \"HWCursor\" \"false\""
  39. }