smplayer-themes-15.12.0.ebuild 760 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils
  5. DESCRIPTION="Icon themes for smplayer"
  6. HOMEPAGE="http://www.smplayer.eu/"
  7. SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
  8. LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 GPL-2 LGPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ~ppc ~ppc64 x86 ~x86-fbsd"
  11. IUSE=""
  12. DEPEND="dev-qt/qtcore:4"
  13. RDEPEND="media-video/smplayer"
  14. src_prepare() {
  15. default
  16. # bug 544108
  17. sed -i -e "s| rcc| \"$(qt4_get_bindir)\"/rcc|" themes/Makefile || die
  18. # bug 544160
  19. sed -i -e 's/make/$(MAKE)/' Makefile || die
  20. }
  21. src_install() {
  22. rm themes/Makefile themes/H2O/Makefile || die
  23. insinto /usr/share/smplayer
  24. doins -r themes
  25. dodoc Changelog README.txt
  26. }