xfce-gant-icon-theme-3.9_p6.ebuild 741 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome2-utils
  5. DESCRIPTION="Xfce Gant Icon Theme"
  6. HOMEPAGE="http://www.xfce-look.org/content/show.php/GANT?content=23297"
  7. SRC_URI="http://overlay.uberpenguin.net/icons-xfce-gant-${PV/_p/-}.tar.bz2"
  8. LICENSE="public-domain"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="x11-themes/hicolor-icon-theme"
  13. DEPEND="${RDEPEND}"
  14. RESTRICT="binchecks strip"
  15. S=${WORKDIR}/Gant.Xfce
  16. src_install() {
  17. dodoc README
  18. rm -f icons/iconrc~ README || die
  19. insinto /usr/share/icons/Gant.Xfce
  20. doins -r *
  21. }
  22. pkg_preinst() { gnome2_icon_savelist; }
  23. pkg_postinst() { gnome2_icon_cache_update; }
  24. pkg_postrm() { gnome2_icon_cache_update; }