aewm++-1.1.5-r2.ebuild 686 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="A window manager with more modern features than aewm"
  6. HOMEPAGE="https://github.com/frankhale/aewmpp"
  7. SRC_URI="mirror://gentoo/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND="x11-libs/libX11
  13. x11-libs/libXext"
  14. DEPEND="${RDEPEND}
  15. x11-proto/xextproto
  16. x11-proto/xproto"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-gcc43.patch \
  19. "${FILESDIR}"/${P}-makefile.patch
  20. }
  21. src_compile() {
  22. emake CXX="$(tc-getCXX)"
  23. }
  24. src_install() {
  25. emake DESTDIR="${D}" install
  26. dodoc ChangeLog README
  27. }