enlightenment-1.0.17.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. if [[ ${PV} == *9999 ]] ; then
  5. ESVN_REPO_URI="https://svn.enlightenment.org/svn/e/trunk/E16/e"
  6. inherit subversion autotools
  7. SRC_URI=""
  8. #KEYWORDS=""
  9. S=${WORKDIR}/e16/e
  10. else
  11. SRC_URI="mirror://sourceforge/enlightenment/e16-${PV/_/-}.tar.gz"
  12. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
  13. S=${WORKDIR}/e16-${PV/_pre?}
  14. fi
  15. inherit eutils
  16. DESCRIPTION="Enlightenment Window Manager (e16)"
  17. HOMEPAGE="https://www.enlightenment.org/"
  18. LICENSE="BSD"
  19. SLOT="0"
  20. IUSE="dbus doc nls pango pulseaudio xcomposite xinerama xrandr"
  21. RDEPEND="pulseaudio? ( media-sound/pulseaudio )
  22. dbus? ( sys-apps/dbus )
  23. pango? ( x11-libs/pango )
  24. =media-libs/freetype-2*
  25. >=media-libs/imlib2-1.3.0[X]
  26. x11-libs/libSM
  27. x11-libs/libICE
  28. x11-libs/libX11
  29. x11-libs/libXext
  30. x11-libs/libXfixes
  31. x11-libs/libXdamage
  32. x11-libs/libXxf86vm
  33. x11-libs/libXft
  34. xrandr? ( x11-libs/libXrandr )
  35. x11-libs/libXrender
  36. x11-misc/xbitmaps
  37. xinerama? ( x11-libs/libXinerama )
  38. xcomposite? ( x11-libs/libXcomposite )
  39. nls? ( virtual/libintl )
  40. virtual/libiconv"
  41. DEPEND="${RDEPEND}
  42. virtual/pkgconfig
  43. x11-proto/xextproto
  44. x11-proto/xf86vidmodeproto
  45. xinerama? ( x11-proto/xineramaproto )
  46. xcomposite? ( x11-proto/compositeproto )
  47. x11-proto/xproto
  48. nls? ( sys-devel/gettext )"
  49. PDEPEND="doc? ( app-doc/edox-data )"
  50. src_prepare() {
  51. if [[ ! -e configure ]] ; then
  52. eautopoint
  53. eautoreconf
  54. fi
  55. }
  56. src_configure() {
  57. econf \
  58. $(use_enable nls) \
  59. $(use_enable dbus) \
  60. $(use_enable pulseaudio sound pulse) \
  61. $(use_enable pango) \
  62. $(use_enable xinerama) \
  63. $(use_enable xrandr) \
  64. $(use_enable xcomposite composite) \
  65. --disable-docs \
  66. --enable-zoom
  67. }
  68. src_install() {
  69. default
  70. dodoc COMPLIANCE sample-scripts/*
  71. dohtml docs/e16.html
  72. }