xfce4-settings-4.13.0.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit fdo-mime gnome2-utils
  5. DESCRIPTION="Configuration system for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="input_devices_libinput libcanberra libnotify upower +xklavier"
  12. RDEPEND=">=dev-libs/dbus-glib-0.100
  13. >=dev-libs/glib-2.24
  14. media-libs/fontconfig
  15. x11-libs/gtk+:3
  16. x11-libs/libX11
  17. >=x11-libs/libXcursor-1.1
  18. >=x11-libs/libXi-1.3
  19. >=x11-libs/libXrandr-1.2
  20. >=xfce-base/garcon-0.2
  21. >=xfce-base/exo-0.11
  22. >=xfce-base/libxfce4ui-4.12
  23. >=xfce-base/libxfce4util-4.12
  24. >=xfce-base/xfconf-4.12
  25. libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
  26. input_devices_libinput? ( x11-drivers/xf86-input-libinput )
  27. libnotify? ( >=x11-libs/libnotify-0.7 )
  28. upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )
  29. xklavier? ( >=x11-libs/libxklavier-5 )"
  30. DEPEND="${RDEPEND}
  31. dev-util/intltool
  32. virtual/pkgconfig
  33. sys-devel/gettext
  34. >=x11-proto/inputproto-1.4
  35. x11-proto/xproto"
  36. DOCS=( AUTHORS ChangeLog NEWS TODO )
  37. src_configure() {
  38. econf \
  39. $(use_enable upower upower-glib) \
  40. $(use_enable input_devices_libinput xorg-libinput) \
  41. $(use_enable libnotify) \
  42. $(use_enable xklavier libxklavier) \
  43. $(use_enable libcanberra sound-settings)
  44. }
  45. pkg_preinst() {
  46. gnome2_icon_savelist
  47. }
  48. pkg_postinst() {
  49. fdo-mime_desktop_database_update
  50. fdo-mime_mime_database_update
  51. gnome2_icon_cache_update
  52. }
  53. pkg_postrm() {
  54. fdo-mime_desktop_database_update
  55. fdo-mime_mime_database_update
  56. gnome2_icon_cache_update
  57. }