xfdesktop-4.12.3.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Desktop manager for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="debug libnotify +thunar"
  12. # src/xfdesktop-file-utils.c:#if GLIB_CHECK_VERSION (2, 38, 0)
  13. RDEPEND=">=x11-libs/cairo-1.6:=
  14. >=dev-libs/dbus-glib-0.100:=
  15. >=dev-libs/glib-2.20:=
  16. >=x11-libs/gtk+-2.24:2=
  17. >=x11-libs/libwnck-2.30:1=
  18. x11-libs/libX11:=
  19. >=xfce-base/exo-0.8:=
  20. >=xfce-base/garcon-0.3:=
  21. >=xfce-base/libxfce4ui-4.11:=
  22. >=xfce-base/libxfce4util-4.11:=
  23. >=xfce-base/xfconf-4.10:=
  24. libnotify? ( >=x11-libs/libnotify-0.7:= )
  25. thunar? (
  26. >=dev-libs/glib-2.38:=
  27. >=xfce-base/thunar-1.6:=[dbus]
  28. )"
  29. DEPEND="${RDEPEND}
  30. dev-util/intltool
  31. sys-devel/gettext
  32. virtual/pkgconfig"
  33. pkg_setup() {
  34. XFCONF=(
  35. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  36. $(use_enable thunar file-icons)
  37. $(use_enable thunar thunarx)
  38. $(use_enable libnotify notifications)
  39. $(xfconf_use_debug)
  40. )
  41. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  42. }