xfwm4-4.12.4.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Window manager for the Xfce desktop environment"
  5. HOMEPAGE="http://www.xfce.org/projects/"
  6. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  10. IUSE="dri startup-notification +xcomposite"
  11. RDEPEND="dev-libs/dbus-glib:=
  12. >=dev-libs/glib-2.20:=
  13. >=x11-libs/gtk+-2.24:2=
  14. x11-libs/libX11:=
  15. x11-libs/libXext:=
  16. x11-libs/libXrandr:=
  17. x11-libs/libXrender:=
  18. x11-libs/pango:=
  19. >=x11-libs/libwnck-2.30:1=
  20. >=xfce-base/libxfce4util-4.10:=
  21. >=xfce-base/libxfce4ui-4.11:=
  22. >=xfce-base/xfconf-4.10:=
  23. startup-notification? ( x11-libs/startup-notification:= )
  24. xcomposite? (
  25. x11-libs/libXcomposite:=
  26. x11-libs/libXdamage:=
  27. x11-libs/libXfixes:=
  28. )"
  29. # libdrm: only headers are used
  30. # libICE/liBSM: not really used anywhere but checked by configure
  31. # https://bugzilla.xfce.org/show_bug.cgi?id=11914
  32. DEPEND="${RDEPEND}
  33. dev-util/intltool
  34. sys-devel/gettext
  35. x11-libs/libICE
  36. x11-libs/libSM
  37. xfce-base/exo
  38. virtual/pkgconfig
  39. dri? ( >=x11-libs/libdrm-2.4 )"
  40. DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
  41. src_configure() {
  42. local myconf=(
  43. $(use_enable dri libdrm)
  44. $(use_enable startup-notification)
  45. --enable-xsync
  46. --enable-render
  47. --enable-randr
  48. $(use_enable xcomposite compositor)
  49. )
  50. econf "${myconf[@]}"
  51. }