xfce4-radio-plugin-0.5.1-r1.ebuild 750 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic multilib xfconf
  5. DESCRIPTION="V4L radio device control plug-in for the Xfce desktop environment"
  6. HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-radio-plugin"
  7. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug"
  12. RDEPEND=">=xfce-base/libxfcegui4-4.8:=
  13. >=xfce-base/xfce4-panel-4.8:="
  14. DEPEND="${RDEPEND}
  15. dev-util/intltool
  16. virtual/pkgconfig"
  17. pkg_setup() {
  18. XFCONF=(
  19. --libexecdir="${EPREFIX}"/usr/$(get_libdir)
  20. $(xfconf_use_debug)
  21. )
  22. DOCS=( AUTHORS NEWS README )
  23. # fix underlinking, bug #555056
  24. append-libs -lm
  25. }