dump-0.4.44-r2.ebuild 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils autotools
  5. MY_P=${P/4./4b}
  6. S=${WORKDIR}/${MY_P}
  7. DESCRIPTION="Dump/restore ext2fs backup utilities"
  8. HOMEPAGE="http://dump.sourceforge.net/"
  9. SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  13. IUSE="debug ermt libressl readline selinux static"
  14. RDEPEND=">=sys-fs/e2fsprogs-1.27
  15. >=app-arch/bzip2-1.0.2
  16. >=sys-libs/zlib-1.1.4
  17. ermt? (
  18. !libressl? ( dev-libs/openssl:0= )
  19. libressl? ( dev-libs/libressl:0= )
  20. )
  21. readline? (
  22. sys-libs/readline:0=
  23. sys-libs/ncurses:=
  24. static? ( sys-libs/ncurses:=[static-libs] )
  25. )"
  26. DEPEND="${RDEPEND}
  27. virtual/pkgconfig
  28. virtual/os-headers"
  29. src_prepare() {
  30. epatch "${FILESDIR}/${P}-underlinking.patch"
  31. epatch "${FILESDIR}/${P}-rl_completion_matches-detection.patch"
  32. epatch "${FILESDIR}/${P}-fix-pointers-aliasing.patch"
  33. epatch "${FILESDIR}/${P}-sysmacros.patch" #580204
  34. eautoreconf
  35. }
  36. src_configure() {
  37. econf \
  38. --with-dumpdatespath=/etc/dumpdates \
  39. --with-{bin,man}owner=root \
  40. --with-{bin,man}grp=root \
  41. --enable-largefile \
  42. $(use_enable selinux transselinux) \
  43. $(use_enable ermt) \
  44. $(use_enable static) \
  45. $(use_enable readline) \
  46. $(use_enable debug)
  47. }
  48. src_install() {
  49. # built on old autotools, no DESTDIR support
  50. einstall MANDIR="${D}"/usr/share/man/man8
  51. mv "${ED}"/usr/sbin/{,dump-}rmt || die
  52. mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
  53. use ermt && newsbin rmt/ermt dump-ermt
  54. dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
  55. dodoc -r examples/*
  56. }
  57. pkg_postinst() {
  58. ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
  59. ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
  60. }