dump-0.4.45.ebuild 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. MY_P=${P/4./4b}
  5. S=${WORKDIR}/${MY_P}
  6. DESCRIPTION="Dump/restore ext2fs backup utilities"
  7. HOMEPAGE="http://dump.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  12. IUSE="bzip2 debug ermt libressl lzo readline selinux sqlite ssl static zlib"
  13. REQUIRED_USE="
  14. ermt? ( ssl )
  15. ssl? ( zlib )
  16. "
  17. RDEPEND=">=sys-fs/e2fsprogs-1.27:=
  18. >=sys-libs/e2fsprogs-libs-1.27:=
  19. sys-apps/util-linux
  20. bzip2? ( >=app-arch/bzip2-1.0.2:= )
  21. zlib? ( >=sys-libs/zlib-1.1.4:= )
  22. lzo? ( dev-libs/lzo:2= )
  23. sqlite? ( dev-db/sqlite:3= )
  24. ermt? (
  25. !libressl? ( dev-libs/openssl:0= )
  26. libressl? ( dev-libs/libressl:0= )
  27. )
  28. ssl? (
  29. !libressl? ( dev-libs/openssl:0= )
  30. libressl? ( dev-libs/libressl:0= )
  31. )
  32. readline? (
  33. sys-libs/readline:0=
  34. sys-libs/ncurses:=
  35. static? ( sys-libs/ncurses:=[static-libs] )
  36. )"
  37. DEPEND="${RDEPEND}
  38. virtual/pkgconfig
  39. virtual/os-headers"
  40. src_configure() {
  41. econf \
  42. --with-dumpdatespath=/etc/dumpdates \
  43. --with-rmtpath='$(sbindir)/rmt' \
  44. --enable-blkid \
  45. --disable-uuid \
  46. $(use_enable selinux) \
  47. $(use_enable ermt) \
  48. $(use_enable static static-progs) \
  49. $(use_enable readline) \
  50. $(use_enable debug) \
  51. $(use_enable sqlite) \
  52. $(use_enable bzip2) \
  53. $(use_enable zlib) \
  54. $(use_enable lzo) \
  55. $(use_enable ssl)
  56. }
  57. src_install() {
  58. default
  59. mv "${ED}"/usr/sbin/{,dump-}rmt || die
  60. mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
  61. use ermt && newsbin rmt/ermt dump-ermt
  62. dodoc KNOWNBUGS MAINTAINERS REPORTING-BUGS
  63. dodoc -r examples
  64. }
  65. pkg_postinst() {
  66. if [[ -z ${REPLACING_VERSIONS} ]] ; then
  67. ewarn "app-arch/dump installs 'rmt' as 'dump-rmt'."
  68. ewarn "This is to avoid conflicts with app-arch/tar 'rmt'."
  69. fi
  70. }