hardlink-0.3.0.ebuild 951 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. DESCRIPTION="A tool which replaces copies of a file with hardlinks"
  6. HOMEPAGE="http://jak-linux.org/projects/hardlink/"
  7. SRC_URI="http://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.xz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. RDEPEND="dev-libs/libpcre"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS="README ${T}/README.rsync"
  16. src_prepare() {
  17. sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
  18. cat <<-EOF > "${T}"/README.rsync
  19. https://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
  20. for excluding rsync temporary files by default.
  21. To accomplish same with this version, you can use following syntax:
  22. # hardlink -x '^\..*\.\?{6,6}$'
  23. This was discussed at https://bugs.gentoo.org/416613
  24. EOF
  25. }
  26. src_compile() {
  27. tc-export CC
  28. emake
  29. }