lzlib-1.6.ebuild 921 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib toolchain-funcs
  5. DESCRIPTION="Library for lzip compression"
  6. HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
  7. SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P}.tar.gz"
  8. LICENSE="libstdc++" # fancy form of GPL-2+ with library exception
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="static-libs"
  12. src_configure() {
  13. # not autotools-based
  14. ./configure \
  15. --enable-shared \
  16. --prefix="${EPREFIX}"/usr \
  17. --libdir="${EPREFIX}"/usr/$(get_libdir) \
  18. CC="$(tc-getCC)" \
  19. CPPFLAGS="${CPPFLAGS}" \
  20. CFLAGS="${CXXFLAGS}" \
  21. LDFLAGS="${LDFLAGS}" || die
  22. }
  23. src_install() {
  24. emake DESTDIR="${D}" LDCONFIG=: install
  25. einstalldocs
  26. # this sucking thing does not support disabling static libs
  27. if ! use static-libs; then
  28. rm "${ED%/}"/usr/$(get_libdir)/*.a || die
  29. fi
  30. }