zopfli-1.0.1-r2.ebuild 922 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Very good, but slow, deflate or zlib compression"
  6. HOMEPAGE="https://github.com/google/zopfli/"
  7. SRC_URI="https://github.com/google/zopfli/archive/${P}.tar.gz"
  8. S="${WORKDIR}/${PN}-${P}"
  9. LICENSE="Apache-2.0"
  10. SLOT="0/1"
  11. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  12. DOCS=( CONTRIBUTORS README README.zopflipng )
  13. PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
  14. # zopflipng statically links an exact version of LodePNG (https://github.com/lvandeve/lodepng)
  15. src_prepare() {
  16. default
  17. tc-export CC CXX
  18. }
  19. # The Makefile has no install phase
  20. src_install() {
  21. dolib.so libzopfli.so*
  22. doheader src/zopfli/zopfli.h
  23. dobin ${PN}
  24. # This version was erroneously not bumped to match ${PV}
  25. dolib.so libzopflipng.so*
  26. doheader src/zopflipng/zopflipng_lib.h
  27. dobin zopflipng
  28. }