keybase-1.0.18.ebuild 917 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils versionator
  5. MY_PV=$(replace_version_separator 3 '-')
  6. DESCRIPTION="Client for keybase.io"
  7. HOMEPAGE="https://keybase.io/"
  8. SRC_URI="https://github.com/keybase/client/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. DEPEND="
  14. >=dev-lang/go-1.6:0"
  15. RDEPEND="
  16. app-crypt/gnupg"
  17. S="${WORKDIR}/src/github.com/keybase/client"
  18. src_unpack() {
  19. unpack "${P}.tar.gz"
  20. mkdir -p "$(dirname "${S}")" || die
  21. mv "client-${MY_PV}" "${S}" || die
  22. }
  23. src_compile() {
  24. GOPATH="${WORKDIR}:${S}/go/vendor" \
  25. go build -v -x \
  26. -tags production \
  27. -o "${T}/keybase" \
  28. github.com/keybase/client/go/keybase || die
  29. }
  30. src_install() {
  31. dobin "${T}/keybase"
  32. }
  33. pkg_postinst() {
  34. elog "Run the service: keybase service"
  35. elog "Run the client: keybase login"
  36. }