clsync-docs-0.4.1.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. MY_PN="${PN%-docs}"
  5. MY_P="${MY_PN}-${PV}"
  6. if [[ ${PV} == "9999" ]] ; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
  9. else
  10. SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  11. KEYWORDS="~amd64 ~x86"
  12. S="${WORKDIR}/${MY_P}"
  13. fi
  14. DESCRIPTION="Clsync and libclsync API documentation"
  15. HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
  16. LICENSE="GPL-3+"
  17. SLOT="0"
  18. IUSE="api +examples"
  19. DEPEND="
  20. virtual/pkgconfig
  21. api? ( app-doc/doxygen )
  22. "
  23. src_configure() {
  24. : # doxygen doesn't depend on configuration
  25. }
  26. src_compile() {
  27. if use api; then
  28. doxygen .doxygen || die "doxygen failed"
  29. fi
  30. }
  31. src_install() {
  32. dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
  33. if use api; then
  34. dohtml -r doc/doxygen/html/*
  35. dodoc -r doc/devel/*
  36. fi
  37. if use examples; then
  38. docinto examples
  39. dodoc -r examples/{production,clsync*}
  40. fi
  41. }