clsync-docs-0.4.2.ebuild 889 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. MY_PN="${PN%-docs}"
  5. MY_P="${MY_PN}-${PV}"
  6. SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
  7. KEYWORDS="~amd64 ~x86"
  8. S="${WORKDIR}/${MY_P}"
  9. DESCRIPTION="Clsync and libclsync API documentation"
  10. HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
  11. LICENSE="GPL-3+"
  12. SLOT="0"
  13. IUSE="api +examples"
  14. DEPEND="api? ( app-doc/doxygen )"
  15. src_configure() {
  16. : # doxygen doesn't depend on configuration
  17. }
  18. src_compile() {
  19. if use api; then
  20. doxygen .doxygen || die "doxygen failed"
  21. fi
  22. }
  23. src_install() {
  24. dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
  25. if use api; then
  26. dodoc -r doc/doxygen/html doc/devel/*
  27. fi
  28. if use examples; then
  29. docinto examples
  30. dodoc -r examples/{production,clsync*}
  31. fi
  32. }