moe-1.6.ebuild 701 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs unpacker
  5. DESCRIPTION="A powerful and user-friendly console text editor"
  6. HOMEPAGE="https://www.gnu.org/software/moe/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
  11. RDEPEND="
  12. sys-libs/ncurses
  13. "
  14. DEPEND="
  15. $(unpacker_src_uri_depends)
  16. ${RDEPEND}
  17. virtual/pkgconfig
  18. "
  19. src_prepare() {
  20. tc-export CXX PKG_CONFIG
  21. sed -i \
  22. -e "/^CXXFLAGS=/d" \
  23. -e "/^LDFLAGS=/d" \
  24. -e "/^CXX=/d" \
  25. configure || die "sed on configure failed"
  26. epatch_user
  27. epatch "${FILESDIR}/${P}-tinfo.patch"
  28. }