uae-0.8.29-r2.ebuild 1.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils autotools
  5. DESCRIPTION="The Umiquious Amiga Emulator"
  6. HOMEPAGE="http://www.amigaemulator.org/"
  7. SRC_URI="ftp://ftp.amigaemulator.org/pub/uae/sources/develop/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="sdl alsa scsi"
  12. DEPEND="sdl? ( media-libs/libsdl
  13. media-libs/sdl-gfx
  14. x11-libs/gtk+:2
  15. alsa? ( media-libs/alsa-lib )
  16. )
  17. !sdl? ( x11-libs/libXext
  18. x11-libs/gtk+:2
  19. )
  20. alsa? ( media-libs/alsa-lib )
  21. scsi? ( app-cdr/cdrtools )"
  22. RDEPEND="${DEPEND}"
  23. src_prepare() {
  24. epatch "${FILESDIR}"/${PN}-0.8.25-allow_spaces_in_zip_filenames.diff
  25. epatch "${FILESDIR}"/${PN}-0.8.25-struct_uae_wrong_fields_name.diff
  26. epatch "${FILESDIR}"/${PN}-0.8.26-uae_reset_args.diff
  27. epatch "${FILESDIR}"/${PN}-0.8.26-underlinking.patch
  28. cp "${FILESDIR}"/sdlgfx.h "${S}"/src || die
  29. eautoreconf
  30. }
  31. src_configure() {
  32. # disabling lots of options, cause many code-paths are broken, these should compile,
  33. # if you want/need other options, please test if they work with other combinations
  34. # before opening a bug
  35. econf --enable-ui --with-x --without-svgalib \
  36. --without-asciiart --without-sdl-sound --enable-threads \
  37. $(use_with sdl) $(use_with sdl sdl-gfx) \
  38. $(use_with alsa) \
  39. $(use_enable scsi scsi-device)
  40. }
  41. src_compile() {
  42. emake -j1
  43. }
  44. src_install() {
  45. dobin uae readdisk
  46. cp docs/unix/README docs/README.unix || die
  47. rm -r docs/{AmigaOS,BeOS,pOS,translated,unix} || die
  48. dodoc docs/*
  49. insinto /usr/share/uae/amiga-tools
  50. doins amiga/{*hack,trans*,uae*}
  51. }
  52. pkg_postinst() {
  53. elog
  54. elog "Upstream recommends using SDL graphics (with an environment variable)"
  55. elog "SDL_VIDEO_X11_XRANDR=1 for fullscreen support."
  56. echo
  57. }