ibus-tutcode-1.0.2-r1.ebuild 718 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="a Japanese TUT-Code input engine for IBus"
  7. HOMEPAGE="https://github.com/deton/ibus-tutcode/"
  8. SRC_URI="mirror://github/deton/${PN}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="test"
  13. RESTRICT="test"
  14. CDEPEND="${PYTHON_DEPS}
  15. >=sys-devel/gettext-0.16.1"
  16. DEPEND="${CDEPEND}
  17. test? ( app-i18n/ibus )"
  18. RDEPEND="${CDEPEND}
  19. app-i18n/ibus"
  20. REQUIRED_USE=${PYTHON_REQUIRED_USE}
  21. src_prepare() {
  22. sed -i -e "s/python/${EPYTHON}/" engine/ibus-engine-tutcode.in || die
  23. }
  24. src_install() {
  25. default
  26. dodoc ${PN}.json.example
  27. }