libtabe-0.2.6.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils libtool autotools multilib
  4. DESCRIPTION="Libtabe provides bimsphone support for xcin-2.5+"
  5. HOMEPAGE="http://packages.qa.debian.org/libt/libtabe.html"
  6. SRC_URI="mirror://debian/pool/main/libt/libtabe/${P/-/_}.orig.tar.gz
  7. mirror://debian/pool/main/libt/libtabe/${P/-/_}-1.1.diff.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ppc x86"
  11. IUSE="debug"
  12. DEPEND=">=sys-libs/db-4.5
  13. x11-libs/libX11"
  14. S=${WORKDIR}/${P}.orig
  15. src_unpack() {
  16. unpack ${A}
  17. cd "${S}"
  18. epatch "${WORKDIR}"/${P/-/_}-1.1.diff
  19. epatch "${FILESDIR}"/${P}-fabs.patch
  20. rm -f configure
  21. elibtoolize
  22. cd script
  23. eautoreconf
  24. cp script/* ./
  25. cp configure ../
  26. cd ..
  27. }
  28. src_compile() {
  29. myconf="--with-db-inc=/usr/include
  30. --with-db-lib=/usr/$(get_libdir)
  31. --with-db-bin=/usr/bin
  32. --with-db-name=db
  33. --enable-shared
  34. --disable-static
  35. $(use_enable debug)"
  36. econf ${myconf}
  37. emake -j1 || die "make failed"
  38. }
  39. src_install() {
  40. emake DESTDIR="${D}" install || die "emake install failed."
  41. dodoc doc/*
  42. }