batti-0.3.8-r3.ebuild 925 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1 gnome2-utils eutils
  6. DESCRIPTION="A upower based battery monitor for the system tray, similar to batterymon"
  7. HOMEPAGE="https://code.google.com/p/batti-gtk/"
  8. SRC_URI="https://batti-gtk.googlecode.com/files/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="libnotify"
  13. RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]
  14. dev-python/dbus-python[${PYTHON_USEDEP}]
  15. || ( sys-power/upower sys-power/upower-pm-utils )
  16. x11-themes/gnome-icon-theme
  17. libnotify? ( x11-libs/libnotify )"
  18. DEPEND=""
  19. DOCS=( AUTHORS ChangeLog )
  20. src_prepare() {
  21. has_version ">=sys-power/upower-0.99" && epatch "${FILESDIR}/${P}-upower-0.99.patch"
  22. }
  23. pkg_preinst() {
  24. gnome2_icon_savelist
  25. }
  26. pkg_postinst() {
  27. gnome2_icon_cache_update
  28. }
  29. pkg_postrm() {
  30. gnome2_icon_cache_update
  31. }