binwalk-2.1.1.ebuild 885 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit distutils-r1
  6. DESCRIPTION="A tool for identifying files embedded inside firmware images"
  7. HOMEPAGE="https://github.com/devttys0/binwalk"
  8. SRC_URI="https://github.com/devttys0/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="graph"
  13. RDEPEND="
  14. $(python_gen_cond_dep 'dev-python/pyliblzma[${PYTHON_USEDEP}]' python2_7)
  15. graph? ( dev-python/pyqtgraph[opengl,${PYTHON_USEDEP}] )
  16. "
  17. python_install_all() {
  18. local DOCS=( API.md INSTALL.md README.md )
  19. distutils-r1_python_install_all
  20. }
  21. pkg_postinst() {
  22. if [[ -z ${REPLACING_VERSIONS} ]]; then
  23. elog "binwalk has many optional dependencies to automatically"
  24. elog "extract/decompress data, see INSTALL.md for more details."
  25. fi
  26. }