byobu-5.112.ebuild 944 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
  7. HOMEPAGE="http://byobu.co"
  8. SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="screen"
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. dev-libs/newt[${PYTHON_USEDEP}]
  16. screen? ( app-misc/screen )
  17. !screen? ( app-misc/tmux )"
  18. src_prepare() {
  19. default
  20. python_fix_shebang .
  21. # Set default system backend to screen
  22. if use screen ; then
  23. sed -i -e 's/#\(BYOBU_BACKEND\).*/\1="screen"/' etc/byobu/backend || die
  24. fi
  25. }
  26. src_install() {
  27. default
  28. # Create symlinks for backends
  29. dosym ${PN} /usr/bin/${PN}-screen
  30. dosym ${PN} /usr/bin/${PN}-tmux
  31. docompress -x /usr/share/doc/${PN}
  32. }