cdctl-0.16.ebuild 535 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils autotools toolchain-funcs
  5. DESCRIPTION="Utility to control your cd/dvd drive"
  6. HOMEPAGE="http://cdctl.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/cdctl/${P}.tar.gz"
  8. LICENSE="free-noncomm"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. DEPEND=""
  13. S="${WORKDIR}/${PN}"
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${PN}-0.16-Makefile.in.patch
  16. eautoreconf
  17. }
  18. src_compile() {
  19. emake CC="$(tc-getCC)"
  20. }