tek-1.3.0.ebuild 934 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. WX_GTK_VER=3.0
  5. inherit udev wxwidgets
  6. DESCRIPTION="GUI tool for upgrading the firmware of a Truly Ergonomic Keyboard"
  7. HOMEPAGE="http://trulyergonomic.com/ https://github.com/m-ou-se/tek"
  8. SRC_URI="https://github.com/m-ou-se/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="all-rights-reserved GPL-3+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE=""
  13. RESTRICT="mirror"
  14. RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}=[X]
  15. virtual/libusb:1
  16. virtual/udev"
  17. DEPEND="${RDEPEND}
  18. app-editors/vim-core"
  19. src_prepare() {
  20. default
  21. setup-wxwidgets
  22. sed -r \
  23. -e '/LIN_STRIP/d' \
  24. -e 's/LIN_CXX/CXX/g' \
  25. -e 's/CXX=/CXX\?=/' \
  26. -e 's/CXXFLAGS=(.*)/CXXFLAGS:=\1 $(CXXFLAGS)/' \
  27. -i "${S}"/Makefile || die
  28. }
  29. src_install() {
  30. newbin tek.lin tek
  31. udev_newrules linux-udev-rules 40-tek.rules
  32. einstalldocs
  33. }
  34. pkg_postinst() {
  35. udev_reload
  36. }