calcurse-4.2.1.ebuild 746 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils autotools multilib-minimal
  5. DESCRIPTION="a text-based calendar and scheduling application"
  6. HOMEPAGE="http://calcurse.org/"
  7. SRC_URI="http://calcurse.org/files/${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 x86"
  11. RDEPEND="sys-libs/ncurses:0="
  12. DEPEND="${RDEPEND}"
  13. DOCS=( AUTHORS NEWS README )
  14. PATCHES=( "${FILESDIR}"/"${P}-tinfo.patch" )
  15. src_prepare() {
  16. default
  17. # Dubious tests.
  18. rm -v "${S}/test"/ical-00{2,4,6}.sh || die
  19. eautoreconf
  20. }
  21. multilib_src_configure() {
  22. ECONF_SOURCE="${S}" econf
  23. }
  24. src_compile() {
  25. multilib-minimal_src_compile
  26. }
  27. src_install() {
  28. multilib-minimal_src_install
  29. }