dvipsk-5.995_p20150521.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. #TL_UPSTREAM_PATCHLEVEL="1"
  5. inherit texlive-common eutils
  6. DESCRIPTION="DVI-to-PostScript translator"
  7. HOMEPAGE="http://tug.org/texlive/"
  8. SRC_URI="mirror://gentoo/texlive-${PV#*_p}-source.tar.xz"
  9. #SRC_URI="${SRC_URI} mirror://gentoo/texlive-core-upstream-patches-${TL_UPSTREAM_PATCHLEVEL}.tar.xz"
  10. TL_VERSION=2015
  11. EXTRA_TL_MODULES="dvips"
  12. EXTRA_TL_DOC_MODULES="dvips.doc"
  13. for i in ${EXTRA_TL_MODULES} ; do
  14. SRC_URI="${SRC_URI} mirror://gentoo/texlive-module-${i}-${TL_VERSION}.tar.xz"
  15. done
  16. SRC_URI="${SRC_URI} doc? ( "
  17. for i in ${EXTRA_TL_DOC_MODULES} ; do
  18. SRC_URI="${SRC_URI} mirror://gentoo/texlive-module-${i}-${TL_VERSION}.tar.xz"
  19. done
  20. SRC_URI="${SRC_URI} ) "
  21. LICENSE="GPL-2"
  22. SLOT="0"
  23. KEYWORDS="alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~s390 ~sh x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  24. IUSE="doc source"
  25. DEPEND=">=dev-libs/kpathsea-6.2.1"
  26. RDEPEND="
  27. !<app-text/texlive-core-2010
  28. !<dev-texlive/texlive-basic-2009
  29. !app-text/ptex
  30. ${DEPEND}"
  31. DEPEND="${DEPEND} virtual/pkgconfig"
  32. S=${WORKDIR}/texlive-${PV#*_p}-source/texk/${PN}
  33. #src_prepare() {
  34. # cd "${WORKDIR}/texlive-${PV#*_p}-source/"
  35. # EPATCH_MULTI_MSG="Applying patches from upstream bugfix branch..." EPATCH_SUFFIX="patch" epatch "${WORKDIR}/gentoo_branch2011_patches"
  36. #}
  37. src_configure() {
  38. econf --with-system-kpathsea
  39. }
  40. src_install() {
  41. emake DESTDIR="${D}" prologdir="${EPREFIX}/usr/share/texmf-dist/dvips/base" install
  42. dodir /usr/share # just in case
  43. cp -pR "${WORKDIR}"/texmf-dist "${ED}/usr/share/" || die "failed to install texmf trees"
  44. if use source ; then
  45. cp -pR "${WORKDIR}"/tlpkg "${ED}/usr/share/" || die "failed to install tlpkg files"
  46. fi
  47. dodoc AUTHORS ChangeLog NEWS README TODO
  48. }
  49. pkg_postinst() {
  50. etexmf-update
  51. }
  52. pkg_postrm() {
  53. etexmf-update
  54. }