texi2html-5.0-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="Perl script that converts Texinfo to HTML"
  5. HOMEPAGE="http://www.nongnu.org/texi2html/"
  6. SRC_URI="mirror://nongnu/${PN}/${P}.tar.bz2"
  7. LICENSE="CC-SA-1.0 FDL-1.3 GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  10. IUSE="unicode"
  11. RDEPEND=">=dev-lang/perl-5.10.1
  12. >=dev-perl/libintl-perl-1.200
  13. unicode? (
  14. dev-perl/Text-Unidecode
  15. dev-perl/Unicode-EastAsianWidth
  16. )"
  17. DEPEND="${RDEPEND}"
  18. DOCS="AUTHORS ChangeLog NEWS README TODO"
  19. RESTRICT="test" #411523
  20. src_prepare() {
  21. # On FreeBSD this script is used instead of GNU install but it comes without
  22. # executable pemissions... Fix it!
  23. chmod +x install-sh || die
  24. }
  25. src_configure() {
  26. local myconf
  27. use unicode && myconf='--with-external-Unicode-EastAsianWidth'
  28. econf \
  29. --with-external-libintl-perl \
  30. $(use_with unicode unidecode) \
  31. ${myconf}
  32. }
  33. src_install() {
  34. default
  35. rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
  36. }
  37. pkg_preinst() {
  38. rm -f "${EROOT}"/usr/bin/${PN}
  39. }