alternate-2.18-r1.ebuild 689 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit vim-plugin eutils
  5. DESCRIPTION="vim plugin: quickly switch between .c and .h files"
  6. HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=31"
  7. LICENSE="alternate"
  8. KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  9. IUSE=""
  10. VIM_PLUGIN_HELPTEXT=\
  11. "This plugin provides a new :A command which will switch between a .c
  12. file and the associated .h file. There is also :AS to split windows and
  13. :AV to split windows vertiically."
  14. PATCHES=(
  15. "${FILESDIR}"/${P}-hh-cc-alternation.patch
  16. )
  17. src_prepare() {
  18. default
  19. }