alternate-2.18-r2.ebuild 934 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit vim-plugin
  5. DESCRIPTION="vim plugin: quickly switch between .c and .h files"
  6. HOMEPAGE="https://github.com/vim-scripts/a.vim"
  7. SRC_URI="
  8. https://github.com/vim-scripts/a.vim/archive/${PV}.tar.bz2 -> ${P}.tar.bz2
  9. http://www.vim.org/scripts/download_script.php?src_id=6347 -> ${PN}.txt
  10. "
  11. LICENSE="alternate"
  12. KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
  13. VIM_PLUGIN_HELPTEXT=\
  14. "This plugin provides a new :A command which will switch between a .c
  15. file and the associated .h file. There is also :AS to split windows and
  16. :AV to split windows vertiically."
  17. VIM_PLUGIN_HELPFILES="${PN}.txt"
  18. PATCHES=(
  19. "${FILESDIR}"/${P}-hh-cc-alternation.patch
  20. )
  21. src_prepare() {
  22. default
  23. mkdir -p "${S}/doc" || die
  24. cp "${DISTDIR}/${PN}.txt" "${S}/doc" || die
  25. }