gtkmm-3.22.0.ebuild 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2 multilib-minimal virtualx
  5. DESCRIPTION="C++ interface for GTK+"
  6. HOMEPAGE="http://www.gtkmm.org"
  7. LICENSE="LGPL-2.1+"
  8. SLOT="3.0"
  9. KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  10. IUSE="aqua doc test wayland X"
  11. REQUIRED_USE="|| ( aqua wayland X )"
  12. RDEPEND="
  13. >=dev-cpp/glibmm-2.49.1:2[${MULTILIB_USEDEP}]
  14. >=x11-libs/gtk+-3.22.0:3[aqua?,wayland?,X?,${MULTILIB_USEDEP}]
  15. >=x11-libs/gdk-pixbuf-2.35.5:2[${MULTILIB_USEDEP}]
  16. >=dev-cpp/atkmm-2.24.2[${MULTILIB_USEDEP}]
  17. >=dev-cpp/cairomm-1.12.0[${MULTILIB_USEDEP}]
  18. >=dev-cpp/pangomm-2.38.2:1.4[${MULTILIB_USEDEP}]
  19. >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
  20. "
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig
  23. doc? (
  24. media-gfx/graphviz
  25. dev-libs/libxslt
  26. app-doc/doxygen )
  27. "
  28. # eautoreconf needs mm-common
  29. src_prepare() {
  30. if ! use test; then
  31. # don't waste time building tests
  32. sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
  33. || die "sed 1 failed"
  34. fi
  35. # don't waste time building examples
  36. sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
  37. || die "sed 2 failed"
  38. gnome2_src_prepare
  39. }
  40. multilib_src_configure() {
  41. ECONF_SOURCE="${S}" gnome2_src_configure \
  42. --enable-api-atkmm \
  43. $(multilib_native_use_enable doc documentation) \
  44. $(use_enable aqua quartz-backend) \
  45. $(use_enable wayland wayland-backend) \
  46. $(use_enable X x11-backend)
  47. }
  48. multilib_src_test() {
  49. virtx emake check
  50. }
  51. multilib_src_install() {
  52. gnome2_src_install
  53. }
  54. multilib_src_install_all() {
  55. einstalldocs
  56. find demos -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
  57. find demos -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
  58. dodoc -r demos
  59. }