libnw-1.30.02.ebuild 652 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="Tools and libraries for NWN file manipulation"
  6. HOMEPAGE="http://openknights.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/openknights/${P}.tar.gz"
  8. LICENSE="openknights"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. IUSE=""
  12. DEPEND="sys-devel/bison
  13. sys-devel/flex"
  14. RDEPEND="!sci-biology/newick-utils"
  15. src_prepare() {
  16. sed -i \
  17. -e '/^CC =/d' \
  18. -e '/^CXX =/d' \
  19. $(find . -name Makefile.in) || die
  20. tc-export CC CXX
  21. }
  22. src_install() {
  23. DOCS="AUTHORS ChangeLog NEWS README README.tech TODO" \
  24. default
  25. }