blackfriday-1.2_p20150720.ebuild 566 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGO_PN=github.com/russross/${PN}
  5. if [[ ${PV} = *9999* ]]; then
  6. inherit golang-vcs
  7. else
  8. KEYWORDS="amd64 ~arm64"
  9. EGIT_COMMIT="8cec3a8"
  10. SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
  11. inherit golang-vcs-snapshot
  12. fi
  13. inherit golang-build
  14. DESCRIPTION="a markdown processor implemented in Go"
  15. HOMEPAGE="https://github.com/russross/blackfriday"
  16. LICENSE="BSD-2"
  17. SLOT="0"
  18. IUSE=""
  19. DEPEND="dev-go/sanitized-anchor-name"
  20. RDEPEND=""