go-snappy-0_pre20160213.ebuild 596 B

1234567891011121314151617181920212223242526
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. EGO_SRC=github.com/golang/snappy
  5. EGO_PN=${EGO_SRC}/...
  6. if [[ ${PV} = *9999* ]]; then
  7. inherit golang-vcs
  8. else
  9. KEYWORDS="~amd64"
  10. EGIT_COMMIT="d1d908a252c22fd7afd36190d5cffb144aa8f777"
  11. SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
  12. inherit golang-vcs-snapshot
  13. fi
  14. inherit golang-build
  15. DESCRIPTION="The Snappy compression format in the Go programming language."
  16. HOMEPAGE="https://${EGO_SRC}"
  17. LICENSE="BSD"
  18. SLOT="0/${PVR}"
  19. IUSE=""
  20. DEPEND=""
  21. RDEPEND=""