nasm-2.11.08.ebuild 823 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit flag-o-matic
  5. DESCRIPTION="groovy little assembler"
  6. HOMEPAGE="http://nasm.sourceforge.net/"
  7. SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ia64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
  11. IUSE="doc"
  12. DEPEND="dev-lang/perl
  13. doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
  14. RDEPEND=""
  15. S=${WORKDIR}/${P/_}
  16. src_configure() {
  17. strip-flags
  18. econf
  19. }
  20. src_compile() {
  21. emake nasmlib.o
  22. emake all
  23. use doc && emake doc
  24. }
  25. src_install() {
  26. emake INSTALLROOT="${D}" install install_rdf
  27. dodoc AUTHORS CHANGES ChangeLog README TODO
  28. if use doc ; then
  29. doinfo doc/info/*
  30. dohtml doc/html/*
  31. dodoc doc/nasmdoc.*
  32. fi
  33. }