polyml-5.5.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit base autotools versionator
  5. # Although the download is called 5.5, after building it poly -v says
  6. # it is 5.5.0.
  7. MY_PV=$(get_version_component_range "1-2" "${PV}")
  8. MY_P="${PN}.${MY_PV}"
  9. DESCRIPTION="Poly/ML is a full implementation of Standard ML"
  10. HOMEPAGE="http://www.polyml.org"
  11. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  12. LICENSE="LGPL-2.1"
  13. SLOT="0/${PV}"
  14. KEYWORDS="~amd64 ~x86"
  15. IUSE="X elibc_glibc +gmp portable test +threads"
  16. RDEPEND="X? ( x11-libs/motif:0 )
  17. gmp? ( >=dev-libs/gmp-5 )
  18. elibc_glibc? ( threads? ( >=sys-libs/glibc-2.13 ) )
  19. virtual/libffi"
  20. DEPEND="${RDEPEND}"
  21. S=${WORKDIR}/${MY_P}
  22. PATCHES=("${FILESDIR}/${PN}-5.5.0-configure.patch"
  23. "${FILESDIR}/${PN}-5.5.0-x-it-basis.patch"
  24. "${FILESDIR}/${PN}-5.5.0-asm.patch")
  25. src_prepare() {
  26. base_src_prepare
  27. eautoreconf
  28. }
  29. src_configure() {
  30. econf \
  31. --with-system-libffi \
  32. $(use_with X x) \
  33. $(use_with gmp) \
  34. $(use_with portable) \
  35. $(use_with threads)
  36. }
  37. src_test() {
  38. emake tests || die "tests failed"
  39. }