btparser-0.24.ebuild 785 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit eutils python-single-r1
  6. DESCRIPTION="Parser and analyzer for backtraces produced by gdb"
  7. HOMEPAGE="https://fedorahosted.org/btparser/"
  8. SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="0/2"
  11. KEYWORDS="amd64 x86"
  12. IUSE="static-libs"
  13. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  14. RDEPEND="${PYTHON_DEPS}
  15. >=dev-libs/glib-2.21:2"
  16. DEPEND="${RDEPEND}
  17. app-arch/xz-utils"
  18. src_configure() {
  19. export PYTHON_CFLAGS=$(python_get_CFLAGS)
  20. export PYTHON_LIBS=$(python_get_LIBS)
  21. econf \
  22. $(use_enable static-libs static) \
  23. --disable-maintainer-mode
  24. }
  25. src_install() {
  26. default
  27. prune_libtool_files --modules
  28. }