caliper-1.5.0.ebuild 718 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. DESCRIPTION="Application Introspection System"
  6. HOMEPAGE="http://computation.llnl.gov/projects/caliper"
  7. SRC_URI="https://github.com/LLNL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="
  13. net-misc/curl
  14. sys-libs/libunwind
  15. dev-libs/papi
  16. "
  17. RDEPEND="${DEPEND}"
  18. #thttps://github.com/LLNL/Caliper/pull/23
  19. #thttps://github.com/LLNL/Caliper/pull/24
  20. #thttps://github.com/LLNL/Caliper/pull/25
  21. PATCHES=( "${FILESDIR}/${P}-cmake.patch"
  22. "${FILESDIR}/${P}-python2.patch"
  23. "${FILESDIR}/${P}-multilib.patch"
  24. )
  25. S="${WORKDIR}/${P^c}"