isl-0.13.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils multilib-minimal
  5. DESCRIPTION="A library for manipulating integer points bounded by linear constraints"
  6. HOMEPAGE="http://isl.gforge.inria.fr/"
  7. SRC_URI="http://isl.gforge.inria.fr/${P}.tar.bz2"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0/13"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
  11. IUSE="static-libs"
  12. RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. DOCS=( ChangeLog AUTHORS doc/manual.pdf )
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
  18. # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
  19. # https://groups.google.com/group/isl-development/t/37ad876557e50f2c
  20. sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
  21. }
  22. multilib_src_configure() {
  23. ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
  24. }
  25. multilib_src_install_all() {
  26. einstalldocs
  27. prune_libtool_files
  28. }