isl-0.14.1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils multilib-minimal
  5. DESCRIPTION="A library for manipulating integer points bounded by linear constraints"
  6. HOMEPAGE="http://isl.gforge.inria.fr/"
  7. SRC_URI="http://isl.gforge.inria.fr/${P}.tar.xz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0/14"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
  11. IUSE="static-libs"
  12. RDEPEND=">=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}]"
  13. DEPEND="${RDEPEND}
  14. app-arch/xz-utils
  15. virtual/pkgconfig"
  16. DOCS=( ChangeLog AUTHORS doc/manual.pdf )
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${PN}-0.07-gdb-autoload-dir.patch
  19. # m4/ax_create_pkgconfig_info.m4 is broken but avoid eautoreconf
  20. # https://groups.google.com/group/isl-development/t/37ad876557e50f2c
  21. sed -i -e '/Libs:/s:@LDFLAGS@ ::' configure || die #382737
  22. }
  23. multilib_src_configure() {
  24. ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
  25. }
  26. multilib_src_install_all() {
  27. einstalldocs
  28. prune_libtool_files
  29. }