libcaldav-0.6.2.ebuild 578 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit base
  5. DESCRIPTION="C library implementing client support for CalDAV"
  6. HOMEPAGE="http://libcaldav.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/libcaldav/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="doc"
  12. RDEPEND="
  13. dev-libs/glib
  14. net-misc/curl[ssl,gnutls(+),curl_ssl_gnutls(+)]
  15. "
  16. DEPEND="${RDEPEND}
  17. doc? (
  18. app-doc/doxygen
  19. virtual/latex-base
  20. dev-texlive/texlive-latexextra
  21. )
  22. "
  23. src_configure() {
  24. econf $(use_enable doc)
  25. }