libclc-0.1.0_pre20150305.ebuild 968 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
  6. if [[ ${PV} = 9999* ]]; then
  7. GIT_ECLASS="git-r3"
  8. EXPERIMENTAL="true"
  9. fi
  10. inherit base python-any-r1 $GIT_ECLASS
  11. DESCRIPTION="OpenCL C library"
  12. HOMEPAGE="http://libclc.llvm.org/"
  13. if [[ $PV = 9999* ]]; then
  14. SRC_URI="${SRC_PATCHES}"
  15. else
  16. SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
  17. fi
  18. LICENSE="|| ( MIT BSD )"
  19. SLOT="0"
  20. KEYWORDS="~amd64 ~x86"
  21. IUSE=""
  22. RDEPEND="
  23. >=sys-devel/clang-3.6:0
  24. >=sys-devel/llvm-3.6:0
  25. <sys-devel/clang-3.7:0
  26. <sys-devel/llvm-3.7:0"
  27. DEPEND="${RDEPEND}
  28. ${PYTHON_DEPS}"
  29. src_unpack() {
  30. if [[ $PV = 9999* ]]; then
  31. git-r3_src_unpack
  32. else
  33. default
  34. mv ${PN}-*/ ${P} || die
  35. fi
  36. }
  37. src_configure() {
  38. ./configure.py \
  39. --with-llvm-config="$(type -P llvm-config)" \
  40. --prefix="${EPREFIX}/usr" || die
  41. }
  42. src_compile() {
  43. emake VERBOSE=1
  44. }