libclc-0.2.0_pre20151006.ebuild 917 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. EGIT_REPO_URI="http://llvm.org/git/${PN}.git"
  6. if [[ ${PV} = 9999* ]]; then
  7. GIT_ECLASS="git-r3"
  8. EXPERIMENTAL="true"
  9. fi
  10. inherit base python-any-r1 $GIT_ECLASS
  11. DESCRIPTION="OpenCL C library"
  12. HOMEPAGE="http://libclc.llvm.org/"
  13. if [[ $PV = 9999* ]]; then
  14. SRC_URI="${SRC_PATCHES}"
  15. else
  16. SRC_URI="mirror://gentoo/${P}.tar.xz ${SRC_PATCHES}"
  17. fi
  18. LICENSE="|| ( MIT BSD )"
  19. SLOT="0"
  20. KEYWORDS="~amd64 ~x86"
  21. IUSE=""
  22. RDEPEND="
  23. >=sys-devel/clang-3.7
  24. >=sys-devel/llvm-3.7"
  25. DEPEND="${RDEPEND}
  26. ${PYTHON_DEPS}"
  27. src_unpack() {
  28. if [[ $PV = 9999* ]]; then
  29. git-r3_src_unpack
  30. else
  31. default
  32. mv ${PN}-*/ ${P} || die
  33. fi
  34. }
  35. src_configure() {
  36. ./configure.py \
  37. --with-llvm-config="$(type -P llvm-config)" \
  38. --prefix="${EPREFIX}/usr" || die
  39. }
  40. src_compile() {
  41. emake VERBOSE=1
  42. }