libclc-0.2.0_pre20160921.ebuild 990 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 )
  5. EGIT_REPO_URI="http://llvm.org/git/${PN}.git
  6. https://github.com/llvm-mirror/${PN}.git"
  7. EGIT_COMMIT="520743b0b72862a987ead6213dc1a5321a2010f9"
  8. if [[ ${PV} = 9999* ]]; then
  9. GIT_ECLASS="git-r3"
  10. EXPERIMENTAL="true"
  11. else
  12. GIT_ECLASS="vcs-snapshot"
  13. fi
  14. inherit python-any-r1 ${GIT_ECLASS}
  15. DESCRIPTION="OpenCL C library"
  16. HOMEPAGE="http://libclc.llvm.org/"
  17. if [[ ${PV} = 9999* ]]; then
  18. SRC_URI="${SRC_PATCHES}"
  19. else
  20. SRC_URI="https://github.com/llvm-mirror/libclc/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz
  21. ${SRC_PATCHES}"
  22. fi
  23. LICENSE="|| ( MIT BSD )"
  24. SLOT="0"
  25. KEYWORDS="~amd64 ~x86"
  26. IUSE=""
  27. RDEPEND="
  28. >=sys-devel/clang-3.9
  29. >=sys-devel/llvm-3.9"
  30. DEPEND="${RDEPEND}
  31. ${PYTHON_DEPS}"
  32. src_configure() {
  33. ./configure.py \
  34. --with-llvm-config="$(type -P llvm-config)" \
  35. --prefix="${EPREFIX}/usr" || die
  36. }
  37. src_compile() {
  38. emake VERBOSE=1
  39. }