libg15-1.2.7-r1.ebuild 567 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
  5. HOMEPAGE="http://g15tools.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc ppc64 x86"
  10. IUSE=""
  11. DEPEND="=virtual/libusb-0*"
  12. RDEPEND=${DEPEND}
  13. DOCS=( AUTHORS README ChangeLog )
  14. src_configure() {
  15. econf \
  16. --disable-static
  17. }
  18. src_install() {
  19. default
  20. find "${ED}" -name '*.la' -exec rm -f {} +
  21. }