liblist-2.4.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2011 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils multilib
  5. DESCRIPTION="This package provides generic linked-list manipulation routines, plus queues and stacks"
  6. HOMEPAGE="http://ohnopub.net/liblist"
  7. SRC_URI="ftp://ohnopublishing.net/mirror/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
  11. IUSE="doc examples static-libs"
  12. RDEPEND="doc? ( media-gfx/transfig
  13. dev-texlive/texlive-metapost
  14. virtual/latex-base )"
  15. DEPEND="${RDEPEND}"
  16. src_configure() {
  17. local myeconfargs=(
  18. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  19. $(use_enable doc docs)
  20. $(use_enable examples)
  21. )
  22. autotools-utils_src_configure
  23. }
  24. src_install() {
  25. autotools-utils_src_install
  26. dodoc README
  27. if use examples; then
  28. insinto /usr/share/doc/${PF}/examples
  29. doins examples/{*.c,Makefile,README}
  30. insinto /usr/share/doc/${PF}/examples/cache
  31. doins examples/cache/{*.c,README}
  32. fi
  33. docompress -x /usr/share/doc/${PF}/{list.0,paper.dvi,examples}
  34. }
  35. pkg_postinst() {
  36. elog "Note that man pages for this package have been renamed to avoid"
  37. elog "name collisions with some system functions. However, the libs"
  38. elog "and header files have not been changed."
  39. elog "The new names are liblist, lcache, liblist_queue, and liblist_stack."
  40. }